Excavation(day) frames drop horribly(stutters) when getting shot by plasma weapons and also when looking at the sun!!

I’m not making a new account for this game fuck that.

I mean i would try anything that bug is a problem maybe reinstalling the game or deleting saved data??

I’ve tried that already before and nothing. It only happens on this game, no other game do I have to summon voodoo magic to get it to run properly.

So I played Excavation day in both privates and pubs yesterday and I didn’t get the fame drops. May just be getting my hopes up but hopefully that curse is lifted for me.

Also after retrying the devs suggestion I didn’t get the audio bug the whole day. Again don’t want to get my hopes up but if it does fix the problem I’ll let you know what to do.

1 Like

Same, I’m still having this issue on standard PS4. It drives me crazy as fuck

Lucky you with the frame drops thing!!!

Yes! Please tell me about the audio bug!!!

I did, and it has no limits since a long ago. I do enjoy how smooth the other maps run!

Drives me crazy too!!! I can take the audio bug, but fighting becomes soooooo fucking hard with frames dropping. I get it on Excavation Day and on Backwater night at the north-west camp… which is weird af that only a part of the map is “bugged”

Essentially you gotta go to the settings, navigate to Communication Method and set it to USB cable. From there keep your controller plugged in when playing and it should fix it. I haven’t gotten it since however you never know when it’ll come back.

Really? OK! I appreciate it man! I’ll tell you how it goes. Wait, just one question: correct me if I’m wrong, but by changing that, I would need to run “wired” controls, am I right?

Try the other way around. Turn limits on.

I tried that many times before, but not after this last update. Will give it a try.

Essentially yeah, you’ll switch it from Bluetooth to USB but if you have a wireless controller with a long usb charger it should work.

Right. I guess I can handle that. Thanks for the tip man! Will give it a try later today.
I just want to point out that it is… Baffling how they find a workaround, but do not fix the damn thing.

So it worked for a private match, but then I was in publics and it was back and strong. Will keep running tests.

Just got Excavation Day in QP, can confirm the fucking thing drops to like 10 frames per second, if even that, when you look anywhere close to the sky. If you’re inside or looking at the ground, its fine. Look even slightly towards the horizon or up and bam: runs like dogshit. Basically unplayable.


That’s exactly my case! I was so happy when it worked, but it was only once. I got the drop one match right after.

sun going super nova on your fps moment


There is still FPS drop on Excavation on PS5.
And at Stargazer camp on Backwater on enlighted locations.

1 Like

I think it happens also on HEADQUARTERS day. Is something about the light fx or shaders or too many assets on screen so much that it chokes the damn console memory (PS4 at least). Or all those mentioned factors combined.

1 Like