PC foliage Transparency Fix

Does anyone know how to turn this off? This happens to foliage close up to the camera and far away trees that may have some kind of distance fog on it.

Maybe there is a way to set a code in the Epic Games Launcher? I tried all types of grahpic settings but none gets rid of it.


1 Like


So to clarify you are talking about the way foliage looks up close like you are clipping through the obj but still have the weird leaf outline in your face.

Then at distance it looks like fog cause of how hot the jungle is so its probably ment to help a cloked pred

No that is how game engines work, its called procedural texture generation.

so they probably made it so the closer u get to like a plant or something else it will put the textures behind you to sleep… so wait let me make a drawing of it…

This transparency has noise pattern. As you can see here:

Ps5 consoles aparently have this turned off.


This is what most game devs use to program their engine to run more optimized… and the closer u get to the point where u cant no longer see IN front of you the more the engine will start like putting the textures to hibernation mode…


Something like that. But this transparency is really annoying. Is it more to do with how my videocard handles transparencies? or is this the engine?

What in the fuck is that?

Unlucky blame the devs for making the game shitty optimized where they have to do this to even grab few extra frames lmfao…

some games even like make it so it gives fake textures that look as real as u would interact with them but they also dont cause fps drops… but i guess illfonic was unable to do that

im lead to believe that all the stuff we see IN front of us is being rendered as we are there in the first place, which causes like a lot of frame drops and poor fps

Thats the transparency i’m talking about. Its got a noise pattern to it but its obviously transparent.
The leaves are basically on the ground while I was down and it obstructed the camera so the engine made it transparent. Its like this throughout the game from start to finish.
Is it not like this on your PC too?

I was looking at a PS5 video capture the other day and they did not have this transparent noise effect whatsoever. The camera had leaves up close all around it.

This is PS5. I kind of want to match the graphics to it:

1 Like

This one isn’t my screenshot but you can see this effect on the trees at a certain distance directly left of our floating gentleman. Its an odd granuallar pixellation to it. My guess is that antialiasing isn’t working properly and somehow a second image is supposed to blend into the noise pattern to make it one co-hesive image but the engine is stopping it.

Well I guess it time to join us then mass

what you are talking about there isnt procedural textures its occlusion.

" Occlusion Culling is a feature that disables rendering of objects when they are not currently seen by the camera because they are obscured ( occluded ) by other objects."

Procedural textures would be tectures generated by a procedure or algorythm of some kind. IE to reduce the work of an artist by making it automated.

Neither of this is responsible for the transparency effect, its simply an art/design decision to make it look like that. it could be totally invisible if they desired.

I personally dont mind the effect. As for in the distance thats a different issue, thats more to save on performance instead of rendering a 100% accurate object/texture you can render a more simplified version based on a LOD system.

1 Like

ok so i’m not going crazy. You guys have it too. It has its benefits over the ps5 where it either is not used or is done differently. At least you can see through leaves which makes it less frustrating.

Everyone has it lmao… i personally do mind it a lot… i wish they left it as it is and not make it transparent… this just shows how like the devs didnt want to like spent time to work on details in the game i guess…

Btw i found more material to make my target isolation re-worked XD

also im gonna keep telling peeps… predators 2010 was a decent af movie that was focusing more on predator culture and pure hunt survival vibes, got close to first predator 1987 movie…

but it gave us more like predator tech

Well if I had the option to turn it off, i would definitely play with it to see what I like to see.

1 Like

Have a look around “dithered transparency mask” or similar for UE4 and see if you can uncover some console variables to alter it via config/INI

foliage.DitheredLOD If greater than zero, dithered LOD is used, otherwise popping LOD is used.

maybe try that one.


place that in the gameusersetting.ini and game.ini and create one called engine.ini and in each file under a header called [/script/engine.renderersettings]

Hmm, it may not be under renderersettings, just in case put it also in each file under a heading called [SystemSettings] just to be sure and a heading called [/Script/Engine.GameUserSettings]

it will work in one of those just not sure wich. so put it in all of em :P

1 Like

although i dont think that its that to be honest but cant hurt to test it

This is more a dithered transparency. but it may have an affect on the distance dithering you are talking about

1 Like

Btw apperently game runs better in fullscreen mode rather than windowed fullscreen… not sure why cause all games run for me about the same between these modes…

I lose about 40 fps when going from epic to cinematic lmao tho… like the shadow quality is the main issue i recken with game optimizations.