Predator stuck in slow walk animation during match

Just had this happen to me twice in one match after the recent patch. Anyone else experiencing this? Pretty much makes you immobile as a Predator right in the heat of combat.


Yep happened to me 2 days ago

Yes, I had it happen as well. I was wondering if it was just me too.

This happens to me almost every match now. Totally game breaking.

Happened twice for me so far

Just happened again and I died. I went to toss the spear and his arm just stayed there. Game breaking. Hopefully a hotfix for this and autoclaim/feed/leap are in the very near future.

At least a YouTuber showed me mercy multiple times in a match when this happened. I did an auto claim too. I ended up winning but only because they were honorable.

1 Like

Edit: my bad. This bug that you mention is probably new.
The one I mentioned in this post was more like a brief “auto walk” forward. Very weird as well.

Yes, I now remember it happening to me as well. But it was more than a week ago, so patch 1.14

I was amazed at how it was timed perfectly to happen exactly in the worst possible moment, right after I started direct confrontation and was about to bail

This appears to be the same bug listed in this other thread here

I’ve had this happen to me on 2 occasions after the update - once in a private match, and once in a public one (which I lost directly because of this bug). I’ve only played around 4 matches since the update.

It may be that this bug was present before the update and I’ve only now encountered it because having purchased the City Hunter, I equipped him with the Smart Disc and Combistick (which I’m sure many will want to do) - both of which appear to be susceptible to this issue. Either way, this is a pretty serious bug that can directly impact the outcome of a match - it needs fixing urgently.

I HATE THIS GLITCH SO MUCH. It usually occurs after I do some ADS action as the predator. I’m just locked there unable to shoot or jump or anything until I get second winded

@Courier is this being worked on?

Just happened to me twice. I think Combi Stick is the cause… DEVS please fix this ASAP. Especially taking into account that we wait like 10+ minutes to play a game.

Ok apparently it happens every match if you try to throw the combistick

It doesn’t happen every match for me but I noticed I happens when I’m in a heated battle and not so much when I’m being very deliberate. Could be wrong though.

Would be glad to hear from Illfonic if they are aware of this bug and if they are working on a fix… right now it’s impossible to use combistick

They are aware

how do you know?

They said so yesterday

Good to hear

Nevermind I am mistaken sorry. It was the two plasma casters they have addressed.

I have had this problem I have fixed it by aiming with the plasma caster the smart disk or the wrist launcher.

this is nonsense